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Computers Laboratory (1)                                     

What is a computer? 

A computer is an electronic device, operating under the control of instructions stored in its 

own memory, that can accept data, process the data according to specified rules, produce 

results, and stores the results for future use. 

The purposes of using a computer 

Computers are used for a wide variety of purposes such as:  

1. Data processing, storing and retrieving for example computers are used to do commercial 

and financial works. 

2. Scientific processing is the use of computers to support science. 

3. Multimedia processing including music operating or recording, videos playing, film and 

video editing, special effects, animation, illustration, etc. 

4. Accessing the internet 

5. Browsing the world wide web (WWW) 

6. Using application programs such as word processing 

7. Playing games 

8. Communicating via email and social media 

9. Designing and building web pages 

 

The general purpose computer model 

All general purpose computers follow the same basic model. The below diagram illustrates the 

flow of data within a desktop computer. Data is input, processed, then either output or sent 

to secondary storage. It is held in main memory while it is being processed.  
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The Central Processing Unit (CPU) receives instructions and data from an input or memory. 

The instructions and data are processed by the CPU and the results are either sent to an output 

or transferred to secondary storage. 

 

A computer has four main functions, it 

a. Collect input(data)                              Input 

b. Processes data     Processing   

c. Produces output   Output 

d. Stores results     Storage 

  

Input: Input is the raw material entered into a computer from the input devices such as a 

keyboard, mouse, camera or scanner. It is the collection of letters, numbers, images etc.  

Process: Process is the operation of data as per given instruction. It is totally internal process 

of the computer system.  

Output: Output is the processed data given by computer after data processing. Output is also 

called as a result. The user can save these results in the storage devices for the future use or 

display them on the output device, such as a monitor, printer or speaker. 

Storage: It is the area where data can be left on a permanent basis for subsequent access by a 

computer processor. 

 

Data and Information 

Data can be defined as a collection of unprocessed items which should be suitable for 

processing by human or electronic machine before it can be turned into something useful. Data 

can include text, numbers, images, audio, and video. 

 

Information is organized or classified data which has some meaningful values for the receiver. 

Information is the processed data on which decisions and actions are based.  

 

 

 

 

 
 Computers process data into information. 

 

 

 

Information Data Processing 
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Window 7 

Desktop Components: 

1. Start Menu. 

2. Taskbar. 

3. Desktop Icon. 

Start Menu 

The Start menu is the main gateway the computer's programs, folders, and settings. It's called 

a menu because it provides a list of choices. 

 

Use the Start menu to do these common activities: 

 Start programs. 

 Open commonly used folders. 

 Search for files, folders, and programs. 

 Adjust computer settings. 

 Get help with the Windows operating system. 

 Turn off the computer. 

 Log off from Windows or switch to a different user account. 

 

Getting started with the Start menu 

To open the Start menu, click the Start button  in the lower-left corner of the screen. Or, 

press the Windows logo key  on the keyboard. 

 

The Start menu has three basic parts: 

 The large left pane shows a short list of programs on the computer. The computer 

manufacturer can customize this list, so its exact appearance will vary. Clicking All 

Programs displays a complete list of programs. 

 At the bottom of the left pane is the search box, which allows the user to look for 

programs and files on the computer by typing in search terms. 
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 The right pane provides access to commonly used folders, files, settings, and features. It's 

also where the user goes to log off from Windows or turn off the computer. 

 

Using Windows Accessories 

Windows comes with several accessories, built-in programs that are extremely useful for 

completing everyday tasks. 

 

Frequently Used Windows Accessories 

Program Description 

Calculator Performs arithmetic calculations 

Notepad 
Creates, edits, and displays text file using basic text 

formatting 

Paint Creates and edits pictures with different extensions 

Run Open program, folder or document 

Snipping Tool Captures different parts of the screen 

Sticky Notes Creates color notes on the screen 

WordPad 
Creates, edits, and displays text document with 

complex formatting 

System Tools 

 Disk Cleanup 

 Disk Defragmenter 

 System Restore 

Ease of Access 

 Ease of Access Center 

 Magnifier 

 On-screen keyboard 

 Windows speech recognition 
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Start the computer and log on securely using a user name and password. 

 First check that all cables are plugged securely into the rear of the machine. 

 Then check that the monitor is turned on. 

 Locate the power switch on the system unit (tower) and press it once to turn on the 

computer. 

 

Shut down the computer using an appropriate routine. 

 Click on button that represents Start   

 Click Shut Down. 

 

 

 Switch User: A Windows feature that enables another user to log in without the original 

user logging off first. 

 

 Log off: To close a user account’s session, closing all open programs and data files and 

unloading all of that user’s personal settings. 

 

 Lock: Locks up the computer while you're away from it. 

 Restart:  Reboots the computer. 

 

 Sleep: A power-saving mode that retains all running programs and open windows in 

computer memory for a super-quick restart. 

 

 Hibernate (found only on laptop computers): Puts the computer into a low-power mode 

after saving all running programs and open windows on the machine's hard drive for a 

quick restart. 
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To place the computer in one of these modes, select it from the Shut Down button’s menu on 

the Start menu.  

 

Searching  

The Search utility allows the user to search for files. To open the Search dialog box: 

 Click on the Start button. 

 Write the file/folder where the user has Start Search. 

  Automatically it will start searching. 

 
 

 

Use available Help functions. 

 Click on button that represents Start  

 Click on Help and Support 

 A window will load up. In Search Help box write what the user needs to search. 
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Computers Laboratory (2)                                     

Computers Types 

The computers are classified into different types according to size, operational principle, generation, 

and purpose.  

1. Computers types based on purpose  

 General purpose computers. 

 Special purpose computers. 

2. Computers types based on data type or operational principle 

 Analog computers 

 Digital computers 

 Hybrid computers. 

3. Computers types based on generation.  

There are five generations of computers. 

4. Computers types based on size. Industry experts typically classify computers in seven 

categories:  

 Personal Computers PC. 

 Mobile Computers and Mobile Devices. 

 Game consoles.  

 Servers    

  Mainframes. 

 Supercomputers. 

 Embedded computers. 

                                               

Window 7 

Taskbar 

The Windows interface includes a special applicational desktop toolbar called the taskbar. The user can 

use the taskbar for switching between openned windows and starting new applications. 

 

 

Add Toolbars to the Taskbar 

The user can add toolbars to the taskbar by right click on taskbar and select Toolbars,  

https://msdn.microsoft.com/en-us/library/windows/desktop/cc144177(v=vs.85).aspx
User
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Or right-clicking on a blank space on the taskbar and choosing Properties, then the Toolbars tab.  

 

 

Manage multiple windows 

All openned windows are represented by taskbar buttons. The user can arrange the openned windows in 

one of three ways: 

 Cascade, which puts windows in a single stack that has been fanned out so that the window titles 

appear. 

 Stacked, which puts windows in one or more vertical stacks depending on how many windows the 

user has opened. 

 Side by side, which places each window—open, but not maximized—on the desktop so the user can 

see all the windows at once. 

 

To arrange the openned windows, right-click on an empty area of the taskbar, then click Cascade 

windows, Show windows stacked, or Show windows side by side. 

 

Show the desktop: to show the desktop window. 

 

Start Task Manager  

Task Manager displays the programs, processes, and services that are currently running on the computer. 

The user can use Task Manager to monitor the computer’s performance or to close a program that's not 

responding. Open Task Manager by right-clicking on the taskbar, and then clicking Start Task Manager. 
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Shut down a non-responding application. 

Sometimes a program / application fails to respond. In this case, the user needs to start task manager in 

order to shut down (close) the program:  

 The easiest way to use Task Manager is to press Ctrl + Alt + Delete on the keyboard. 

 The below window will open. The user will see a list of things which the user can choose from. It’s 

important that the user click on Start Task Manager. 

 

 Then, the new window shows a list of all currently running tasks, or programs. If a program is having 

a trouble, the “Not responding”  status will likely appear. Click on the program that is not responding and 

click End Task. 

 
 The End Program dialog box will be displayed. 

 Click End Now button. 
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Changing Windows 7 Taskbar Properties 

The user can customize the Taskbar by hiding it, making it bigger or smaller, or doing other things to it, to 

get to the customization window, right-click an open area of the Taskbar and left-click the "Properties" 

title.  

 Lock it. When "Lock the taskbar" is checked, no one can make changes to its size or placement on 

the desktop.  

 Auto-hide. If the user checks this box, it will hide the Taskbar, so that the user can't see it. 

 Use small icons. This will shrink the Taskbar and icons, freeing up more space but still allowing the 

user Taskbar functionality. This is a good option on small screens like laptop or netbook screens. 

 Move the Taskbar. The drop-down menu "Taskbar location on screen:" allow the user to move the 

Taskbar to the top, or either side, of the desktop. Again, most people are used to seeing it at the bottom and 

leave it there. 

 Taskbar buttons. Here the user can change the appearance of the icons in the Taskbar. The user can 

turn off "combining" of icons, meaning that if the user has three Microsoft Word documents open, for 

example, each document will appear as its own icon in the Taskbar, rather than two "hiding" behind a 

single Word icon.  

 

To Modify the Power Button 

Under the Start Menu tab, the user can modify how the Power Button responds. To make modify power 

button, right-click the taskbar, select properties, and select start menu and then change power button 

action. 
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Notification area 

The notification area is located at the right end of the taskbar and contains program icons that provide 

status and notifications. The notification area is used to provide: 

 Easy access to different system functions: the date and time, volume, network, the action center, the 

active keyboard input language, etc. 

 System notifications: the notification balloons that pop in the notification area. For example, when a 

USB stick is successfully removed, the user is notified about it. 

 Show the desktop 

 

 Easy access to applications that display their icon in the notification area. 

 

The simplest way to select which icons and notifications appear in the notification area is to click or tap the 

arrow displayed on the left side of the notification area and then the Customize link. 
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Computers Laboratory (3)                                         

The Components of a computer 

Every computer is composed of two basic components: hardware and software.  

Hardware refers to the physical components, which are any part that the user can either see or 

touch.  

Software refers to the component that is responsible for directing the work to the hardware.  

      

Hardware includes: 

 Input Device: Allows you to enter data and instructions into a computer such as 

keyboard, mouse, camera, microphone and scanner. 

 Output Device: Hardware component that conveys information to one or more people 

such as monitor, printer and speaker. 

 System Unit (Case): contains the electronic components of the computer that are used to 

process data. 

 Storage Device: Records (writes) and/or retrieves (reads) items to and from storage 

media. 

 Communications Device: Enables a computer to send and receive data, instructions, 

and information to and from one or more computers or mobile devices. 

 

 

System Unit The system unit is one of the five main hardware components of a computer. It is 

usually a rectangular container within which other important internal hardware components can 

be found. 

External components of the system unit 

External components are the visible parts of the system unit.  

1. Power switch  .  

2. Reset button   .  

3. Optical Drive. 

4. Headphone & microphone ports 

5. USB ports. 
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Internal components of the system unit 

The internal components of the system unit are: 

 

1. Motherboard also known as the system board or the main board is the largest electronic 

circuit board in the computer. It serves as a single platform to connect all of the parts of 

a computer together. A motherboard connects CPU, memory, hard drives, video card, 

sound card, and other ports directly or via cables. 

2. Processor or Central Processing Unit (CPU) is considered the brain of the computer. 

It is a hardware component responsible for all operations that is carried out in the 

computer’s system. 

3. Random Access Memory (RAM) is the main memory of the computer system whose 

main function is to store data temporary. 

4. Compact Disc (CD) drive, can read, write, erase and re-write a Compact disc(CD).  

5. Hard disk or Hard drive is the secondary storage device of the computer system. It 

stores information, files and other documents permanently  

6. Floppy Disk Drive is used to read and write from or on a floppy disk 

7. Fan is used to cool down and maintain temperature within the system unit. 

8. Power Supply: Because components of the system units do not work with the power 

from your wall socket, the computer power supply unit receives the alternating current 

(AC) and converts it to a controlled direct current (DC) for the components to function. 

9. video and sound cards enable the computer to play videos and sounds respectively 

10. Ports allow the computer user to connect items to the system unit to be explored,  

11. Cables are used to connect the components to each other 
 

Window 7 

Pinning 

In Windows 7 operating system, the user can pin favorite programs anywhere on the taskbar 

for easy access. Press right-click on the opened program button in the task bar and select Pin 

this program to taskbar. 

 

 

 

 



First Class/ Biotechnology Dep. / Mela G. Abdul-Haleem                                                                                                                                                       

15 
 

File and Folder 

All the data on the hard drive consists of files and folders.   

File Folder 

A file is commonly referred to as a 

document and usually created from within a 

specific program. 

A folder is a container for programs or 

files and a method of organizing 

information. 

Files store data, whether text, music or film Folders store files and other folders. 

Files are represented with an icon and 

usually include a symbol of the associated 

program. 

Folders are represented with a yellow 

icon. 

 

Each file has its own extension. A folder does not have any extension. 

Files are taking spaces on computer 

memory. 

Folders are not taking spaces on 

computer memory. 

The user cannot create any folder or sub 

folder within a file. 

The user can create different types of 

files or sub folders in a folder. 

 

 

Selecting Files, Folders and Sub-folders  

 To select an individual file / folder simply click once on the file / folder. The file / folder 

will be highlighted in blue.   

 

 To select a number of adjacent files / folders. Click on the first file / folder in the block 

you wish to select, then press Shift with Arrow key and keep pressing these keys whilst 

clicking on the last file / folder in the block.   
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 To select a number of non-adjacent files / folders. Click on the first file / folder that you 

wish to select. Then press the Ctrl, whilst clicking on the other files / folders that you 

wish to select.   

                          

 

Creating Folders / Sub-folders 

 Identify the area where the user will create the new folder, e.g. Desktop or My 

Documents.   

 Right click on any empty space, point to New, and then click Folder.  

 A new folder will be created and the user can use the keyboard to type a name for the 

folder.  
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Changing the name of a Folder / File 

 Right click on the folder / file.  

 Click Rename.  

 Type a new name. 

 

Saving a File 

When the user saves a document for the first time, the user needs to give it a name. To save a 

file, follow this procedure:  

 Click File, Save As.  

 From the Save in: drop down box select the disk and folder where the document file will 

be saved. 

 Type a name for the document in the File Name: box.  

 Click Save.   
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Duplicating (Moving) Files and Folders from one folder / directory to another.  

 Select the files / folders you wish to duplicate / move.  

 Right click on the folder / file, then click Copy (to duplicate) or Cut (to move).  

 Open the folder where you want to paste the files / folders and right click on any empty 

space, click Paste.  
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Computers Laboratory (4)                                      

Central Processing Unit (CPU) also called a processor, is located inside the computer case on the 

motherboard. It consists of the following features: 

 CPU is considered as the brain of the computer. 

 CPU performs all types of data processing operations. 

 It stores data, intermediate results, and instructions (program). 

 It controls the operation of all parts of the computer. 

 

CPU itself has the following three components: 

1. Memory Unit : This unit can store instructions, data, and intermediate results. 

2. Control Unit: This unit controls the operations of all parts of the computer but does not carry out any 

actual data processing operations. 

3. ALU (Arithmetic Logic Unit): perform arithmetic and logic operations like addition, subtraction, 

multiplication, division, comparing, matching, and merging of data.. 

 

 

Memory  

Memory is primarily of three types: 

1. Cache Memory 

2. Primary Memory/Main Memory 

3. Secondary Memory 

 

1-Cache Memory 

Cache memory is a very high speed semiconductor memory which can speed up the CPU. It acts as a buffer 

between the CPU and the main memory. It is used to hold those parts of data and program which are most 

frequently used by the CPU. 

 

2-Primary Memory (Main Memory) 

It is divided into two subcategories RAM and ROM. 

 

 RAM (Random Access Memory) is the internal memory of the CPU for storing data, program, and 

program result. It is read/write memory which stores data until the machine is working. RAM is volatile, 

i.e. data stored in it is lost when we switch off the computer.  

 ROM (Read Only Memory) is the memory from which we can only read but cannot write on it. This 

type of memory is non-volatile. The information is stored permanently in such memories during 

manufacture. A ROM stores such instructions that are required to start a computer. This operation is 

referred to as bootstrap. 
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The differences between RAM and ROM are shown in the following table: 

 Key RAM ROM 

1 Definition RAM stands for Random Access Memory. ROM stands for Read Only Memory. 

2 
Data 

Retention 

RAM data is volatile. Data is present till 

power supply is present. 

ROM data is permanent. Data remains 

even after power supply is not present. 

3 Data Access RAM data can be read, erased or modified. ROM data is read only. 

4 Usage 
RAM is used to store data that CPU needs 

for current instruction processing. 

ROM is used to store data that in needed to 

bootstrap the computer. 

5 Speed RAM speed is quite high. ROM speed is slower than RAM. 

6 CPU Access 
CPU can access data stored on RAM. Data to be copied from ROM to RAM so 

that CPU can access its data. 

7 Capacity 
RAM memory is large and high capacity. ROM is generally small and of low 

capacity. 

8 Cost RAM is relatively expensive memory. ROM is cheaper than RAM 

 

Window 7 

Delete Files/Folders   

 To delete a file, simply right click on it and click Delete. The same procedure can apply for a folder.   

 The deleted files and folders are placed in the Recycle Bin where the user can permanently delete or 

restore them.  

 

To permanently delete a file / folder: 

 Double left click on the Recycle Bin, then right click on the file / folder that the user  wishes to remove 

permanently, then click on delete. 

                                                           

Restore files, folders from the recycle bin 

To restore a file / folder:   

 Right click on the file / folder (in the Recycle Bin) and click on restore. The file will be restored to its 

original location. 

 

Empty the recycle bin. 

There are two ways to empty the Recycle Bin: 
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 Either double click on the Recycle bin to open it.  Click on Empty Recycle Bin tab. 

 

 Or right click on the Recycle Bin icon, Click, Empty Recycle Bin   

 

 

Creating Desktop Shortcut Icons 

Sometimes it might be necessary for the user to create a shortcut on the desktop. Usually the reason behind this 

is that the user uses a particular file / folder on a regular basis and the user wants to be able to open it easily 

and quickly. To create a new shortcut:   

 Right click on a file / folder.   

 Move the pointer to send to.  

 Click Desktop (Create Shortcut). A shortcut to that file / folder will be created on the desktop.   

 

Creating a Shortcut to another Location on the Computer   

 Right click on a file / folder.  

 Click create shortcut.  

 The shortcut will be created next to the selected file / folder.  
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Open a window to display folder name, size, and location on a drive. 

 Right click on the folder. 

 Click Properties. The following window will appear:   

 

Desktop Icons 

An icon is a small graphical representation of a program or file. When the user double-click an icon, the 

associated file or program will be opened.  

 

https://www.computerhope.com/jargon/d/doublecl.htm
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 Computer icon.       

 My Documents icon.       

 Recycle bin icon.    

 

The opened windows contains three buttons in its title bar:  

 

The Windows Explorer Views 

The Views icon allows the user to set the view to display files.  Open documents icon from desktop or from 

start menue, select view menu 

 

The down arrow displays the following options. 
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 Extra large icons and Large icons : Displays larger icon sizes compared to other views with their 

names. 

 Medium icons - Displays medium-sized icons of the files and folders with their names. 

 Small icons - Displays small icons of the files and folders with their names.  

 List: Displays all files/folders in list format split into multiple columns. 

 Tiles: Displays only the file titles.  

 Details: Displays all files and associated file details such as name, size, type, and last accessed date in a 

single column.  

 Content - Displays medium-sized icons, with the file name, type, size, and dates. 

Sort files  

The files displayed in Documents window can be sorted by name, size, file type and Date / time of last 

modification:  

 Click View, Details.  

 

 Click the appropriate header: 
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Memory & Ports 
3. Secondary Memory This type of memory is also known as external memory or non-volatile memory. It is 

slower than the main memory. These are used for storing data/information permanently. CPU directly does 

not access these memories, instead they are accessed via input-output routines. The contents of secondary 

memories are first transferred to the main memory, and then the CPU can access them.  

 

The most common forms of secondary storage devices:  

 Hard Disk Drive (HDD) are non-volatile magnetic storage devices capable of storing vast amounts of 

data. An electromagnet in the read/write head charges the disk’s surface with either a positive or 

negative charge, this is how binary 1 or 0 is represented. 

 Solid State Drive (SSD) are non-volatile storage devices capable of holding large amounts of data. 

They use flash memories (millions of transistors), giving them the advantage of having no mechanical 

moving parts and therefore immediate access to the data. It is faster than HDD. 

 Compact disc (CD) / Digital Versatile Disc (DVD) are optical devices. Data is burned onto the 

surface of the disk using a laser in these drives. A laser is also used to read the data stored on the 

disk. A CD can store around 650 Mb of data. DVD can store about 4.7Gb-9Gb.  

 Universal Serial Bus Flash Memory (USB Flash Memory) are non-volatile solid state storage 

devices which use flash memories (millions of transistors) to store data.  

 

             

Ports 
A port is a connection point used as an interface between the computer & the peripherals like keyboard, 

mouse, printer, display unit, monitor, flash drive and speaker, etc. There are several types of external ports that 

usually come with a computer: 

 

Parallel ports 
Used for scanners and printers. Also called printer port 

 

Serial ports 
Used for external modems  

 

PS/2 Port 

Used for old computer keyboard and mouse 
 

USB (Universal Serial Bus) ports 

It can connect all kinds of external USB devices such as external hard disk, 

printer, scanner, mouse, keyboard, etc.  

VGA Port  
VGA stands for Video Graphics Array. It connects monitor to a computer's 

video card.  
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Window 7 
 

Customizing the Desktop 

Right click in an empty space on the desktop. Click on Personalize.  

Click on Desktop Background. 

 

Select a picture then save change. Or click on Browse. Select background from file browser windows. Click 

Ok then save change 
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Change the Screen Saver 

Click on Personalization then on Screen Saver. From the window given choose the screen saver by clicking on 

the arrow under the text Screen Saver and choose from the list given 

 

 

 Preview to see how the screen saver looks like. Also change the minutes to wait before the screen saver 

appears. 

 

Change Screen Pixel Resolution 

 Right click in an empty spot on the desktop. Click on Screen Resolution.  
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From there one can change the Resolution. 

 

 
 

Print Screen  

The user may be required to capiture full screen images from the computer screen to do this: 

 Locate the print screen button on the keyboard and press it once. This will take a picture of the current 

screen.   

 Open a document (e.g. Word processor or Paint), and click Paste.  

 

Cleaning Up the Disk 

The user can safely remove redundant or unnecessary files from the hard disk by using the Disk Cleanup 

program. These files consist of temporary files that Windows creates or makes copies of when installing or 

uninstalling programs, paths to Web sites visited, temporary data files, or the status of an application program 

when it stopped responding. 

Disk cleanup can be run using one of the following methods: 

 Click Start→ All Programs→ Accessories→ System Tools→ Disk Cleanup, select the hard drive the 

user wants to clean up and click OK. 

 Open My Computer. Right-click the local disk, then click Properties. Click the General tab and then 

Disk cleanup.  
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The length of time to calculate the space depends on when this command was last used. Once Disk Cleanup 

finishes from calculating the amount of space the user may be able to free up, the user will see a dialog box 

similar to: 

 

 

Defragmenting the Disk  

A file may be stored in a single contiguous space or in the first space available. Over time, Fragmentation 

occurs when the file system cannot or will not allocate enough contiguous space to store a complete file as a 

unit, but instead puts parts of it in gaps between existing files. The Disk Defragmenter program reorganizes 

how information is stored on a hard disk so files reside in a contiguous section. This is also called the 

“Defrag”, and a common method to reduce problems with accessing information or speed up the access time. 

Disk Defragmenter runs on a schedule, but you can also analyze and defragment your disks and drives 

manually.  

 

Disk Defragmenter can be run using one of the following methods: 

 Click Start, All Programs→Accessories→ System Tools→ Disk Defragmenter. 

 Open My Computer. Right-click the local disk to defragment, then click Properties. Click the Tools tab 

and then Defragment Now.  

 

To determine if the disk needs to be defragmented or not, click Analyze disk. Once Windows is finished 

analyzing the disk, you can check the percentage of fragmentation on the disk in the Last Run column. If the 

number is above 10%, you should defragment the disk. Click Defragment disk. 

 

.    

 

 

 

 

 

 

 

 

 

https://en.wikipedia.org/wiki/File_system
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Software 
Software is any set of instructions that tells the hardware what to do. System software is responsible for 

controlling and managing the hardware components of a computer system. There are three types of software:  

 Operational Software (Operating System).  

 Application Software.  

 Programming language. 

 

Operating System is a special type of programs which is loaded automatically when the user starts the 

computer. Four popular personal computer operating systems are Windows, Mac OS, Unix and Linux. 

 

Application Software includes programs designed to make users more productive and/or assist them with 

personal tasks. Application software has a variety of uses:  

1. To make business activities more efficient.  

2. To assist with graphics and multimedia projects.  

3. To support home, personal, and educational tasks.  

4. To facilitate communications. 

Types of application softwares 

- Word-processing software ( enables the user to create and edit documents such as MS-word, Notepad, 

Wordpad etc.). 

- Spreadsheet software (allows users to perform calculations. They simulate paper worksheets by 

displaying multiple cells that make up a grid such as Excel, Lotus 1-2-3 and Apple Numbers). 

- Presentation Software (is the software used to display information in the form of a slide show such as 

Microsoft PowerPoint. 

- Database Software (allows the users to store and retrieve data from databases such as Oracle, 

MSAccess, etc). 

- Multimedia Software ( It allows the users to create and play audio and video media. It is capable 

of playing media files such as Real Player and Media Player. 

- Graphic design Software (allows the users to produce pictures, advertisements such as photoshop, 

etc).  

 

Programming Languages are commands that users activate to complete a task.  

- Low level language or Machine Level Language 

- Assembly Level Language or Middle level language 

- High Level Language. Popular programming languages include C++, Visual C#, Visual Basic, 

JavaScript, and Java. 

 

 

A programmer develops software or writes the instructions that direct the computer to process data into 

information. 
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Windows 7  

Control Panel  
The Control Panel in Windows 7 is the place to make changes to various settings of the computer system and 

to control most Windows commands and features using the various options and sliders in the Control Panel. To 

open the Control Panel, click the Start button on the taskbar and then click Control Panel on the Start menu. 

Windows 7 has three different views for looking at the computer’s Control Panel. 

 

A.Category view  

By default, the Control Panel is displayed in Category view, which is separated into eight categories: System 

and Security, User Accounts, Network and Internet, Appearance and Personalization, Hardware and Sound, 

Clock, Language, and Region, Programs and Ease of Access. 

 
B. Icon views 

The Control Panel’s other two views are Large Icons view and Small Icons view. When the Control Panel is in 

one of the icon views, Windows displays an alphabetical listing of the more than 50 Control Panel programs 

on the system. 

 

System and Security 

View the computer’s basic system information  

 Click on system and security in Control Panel. 

 Click on System.  
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 The following window will be displayed:  

 

Also to view the computer’s basic system information right click on My Computer icon on the desktop and 

select properties from drop down window. 
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Hardware and Sound 

 

Mouse: In the Control Panel, click Hardware and Sound and then click Mouse under the Devices and Printers 

heading.  

 
This will open the Mouse Properties dialog box: 

 
 

Button configuration if the user is left-handed; he needs to reverse the function of the left and right mouse 

buttons.  
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Double Click Speed the double-click is an important skill that needs to be masters. Double-click can launch an 

application or open a file folder or CD. 

Select shapes of Mouse Pointer on the Pointers tab the user can choose the type of pointer the mouse is to 

have when it moves, when it is busy, when it is used etc. 

 
 

Mouse Pointer Speed  

Sometimes changing the speed with which the Mouse reacts by moving the pointer on the line. To move the 

pointer, drag and drop it onto a new position. Click on the Pointer Options tab. Drag to slide to the right to 

increase the pointer speed. 
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View and manage devices  

To see all the devices connected to the computer, click Hardware and sound in Control Panel. Click Devices 

and Printers.  

 
 

Changing the Default Printer 

The default printer is the printer to which a computer sends documents when selecting the Print command 

without first specifying which printer wanting to use with a program. There is only one default printer; it 

should be the printer that is using most often. To set a printer as the default printer:   

 Click Hardware and Sound in Control Panel. 

 Click Devices and Printers. 

 The Devices and Printers window appears, showing a list of printers will be displayed.  

 Right-click the name of the printer to set as a default printer.  

 Click Set as Default Printer. The icon of selected printer will display a checkmark on the buttom left 

corner of the icon.  
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Or press the start menu and click Devices and Printers and then right-click the name of the printer to set as a 

default printer and click Set as Default Printer. 

 

Setting the computer sound volume 

In this case be careful not to make any changes, but simply know how to make setting the computer sound 

volume. 

 Click on the Hardware and Sound command in Control Panel. 

 

 This will display the Hardware and Sound dialog box. 

 Within the Sound section click on the Adjust system volume link. 
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The user will see a slider control display and modify the computer volume. 

 
 

Change the power setting 

The user might want to change plans to save battery power on the laptop, or reduce energy consumption on a 

desktop at home or the office.  

 Click Hardware and sound, click "Power Options" 

 Click "Change battery settings". Click change plan settings. Select the power profile the user 

desire. 

 

 
 

 

 



First Class/ Biotechnology Dep. / Mela G. Abdul-Haleem                                                                                                                                                       

38 
 

Computers Laboratory (7)                                       

Storage Units 
Bit (binary digit) refers to the smallest unit of information that can be stored in a machine. A bit has a 

single binary value, either 0 or 1.  

 

Nibble : is a group of 4 bits  

 

Byte : it is the basic unit in computer memory that is representing only one character. A character can be a 

number, letter or symbol. One byte represents eight bits.  

There is also binary code for uppercase and lowercase letters: 

 

The following table lists of storage units: 

 

Unit Shortened Capacity 

Bit b 1 or 0 (on or off) 

Byte B 1B=8 bits 

Kilobyte KB 1KB=1024 bytes 

Megabyte MB 1MB=1024 kilobytes 

Gigabyte GB 1GB=1024 megabytes 

Terabyte TB 1TB=1024 gigabytes 

Petabyte PB 1PB=1024 terabytes 

Exabyte EB 1EB=1024 petabytes 

Zettabyte ZB 1ZB=1024 exabytes 

Yottabyte YB 1YB=1024 zettabytes 

 

Factors affect the computer performance  

1. Speed of CPU. 

2. Size of RAM. 

3. Speed and size of hard disk. 

4. Multiple processes running on computer. 

5. Video card. 

 

Security and Keeping Information Safe 

 

Information Security is a general term used to describe all kinds of security in a computerized environment. 

Information Security is not only about securing information from unauthorized access. Information Security is 

basically the practice of preventing unauthorized access, use, disclosure, disruption, modification  or 

destruction of information.  

 

The ways a virus can be transmitted onto a computer 

 Downloads from the Internet. 

 Pirated software. 

http://searchcio-midmarket.techtarget.com/definition/binary
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 Exchange of diskettes. 

 In attachments to emails and in emails themselves. 

 In documents. Macro-viruses can be hidden in ordinary documents, spreadsheets and presentations. 

Macro-viruses make use of a special customization feature in applications called macros. Macros allow 

you to create mini-programs to carry out certain tasks in your applications. 

 

There are a number of measures the user can take to protect themself from viruses: 

• Install good anti-virus software and update it on a regular basis.  

• Scan all diskettes before reading them and be careful of using diskettes from unknown sources. 

• Enable the auto-protection feature on the anti-virus software to scan emails. 

• Be wary of emails from unknown sources, particularly if they contain attachments.  

• Do not download files/software from unknown Internet sites. 

Windows 7 

Control Panel 

Programs 

Removing Programs  

Sometimes, programs can stop being useful or even start harming the computer, so it necessary to remove 

them. 

Open Programs and Features.  

 The Control Panel is typically displayed in one of two different ways:  

 In Category view, click the “Uninstall a program” link under the “Programs” category 

 In Icon view, click the “Programs and Features” icon. 
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Appearance and Personalization 

Changing the Desktop Background 

 Clicks on Appearance and Personalization. 

 
 

 Click on Personalization 

 

 Click on Desktop Background. 
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 Select a picture then save change. Or click on Browse. Select background from file browser windows.  

 Click save change.  

  

Change the Screen Saver 

 Click on Personalization. Click on Screen Saver.  

 From the screen saver settings window, choose the screen saver by clicking on the arrow under the text 

Screen Saver and choose from the given list.  
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 Preview to see how the screen saver looks like. Also change the minutes to wait before the appearance 

of  the screen saver. 

 

Open Taskbar and Start menu Properties from Control Panel 

Open Taskbar and Start Menu Properties by clicking Control Panel, clicking Appearance and 

Personalization, and then clicking Taskbar and Start Menu. 

 



First Class/ Biotechnology Dep. / Mela G. Abdul-Haleem                                                                                                                                                       

43 
 

 

Show/ Hide the Hidden Files and Folders  

Windows 7 hides important folders and files in order to keep users’ files from modifying or deleting and 

subsequently damaging their files. Windows 7 does not show hidden files by default. To show hidden files and 

folders 

 Click on Appearance and Personalization. 

 Under Folder Options, Click show hidden files and folders. 

 

http://www.wikihow.com/Show-Hidden-Files-in-Windows-7
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 Inside View tab in the Folder Options window, click show hidden files, folders, or drives and then click 

OK. The hidden files and folders will be shown. 

 

 

Adding Fonts  

 Click Appearance and personalization command in Control Panel. 

 The fonts that are installed in the computer can be seen by going to the Fonts Window. It is installed as 

part of the Operating System (OS).  

 Then Click on Fonts. 
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 The user will see the following: 

 

 By selecting a font , the user can preview, delete, or hide or show the selected font. 
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Clock, Language, and Region 

 

Modifying the computer date and time 

 Click on the Start button. Click on Control Panel, and then Click on the Clock, Language, and Region. 

 
 

 To set the date and time, click on the Date and Time command. This will display the Date and Time 

dialog box, allowing to change the date or time. 
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 Click on the Change date and time button and change the date and time as required. Then click OK. 
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The user can also access to date and time by click the Date/Time displays on the right end of the taskbar, and 

click Change Date and Time settings from the small window that appears. The Date and Time dialog box 

appears. Click the Change Date and Time button. 

 

 

 

Change Region, and Language 

 Click on Clock, Language, and Region command in Control Panel. Click on Region and Language 

dialog box will be displayed. Click on Location tab.  

 

 

 Or Click on the Change location link under Region and Language . If necessary click on the down 

arrow to display a list of countries, from which pick the particular country. 
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 Click on the Keyboards and Languages tab. Click on the Change keyboards button. This will 

display a dialog box allowing selecting and change the Default input language.  

 

 

Adding/ Removing keyboard settings can also be done. To add or remove a non default keyboard language, 

select the language  and then Click on the Add button or Remove button. 
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Start → All programs → Accessories → Calculator  

Start → All programs → Accessories → Notepad  

Start → All programs → Accessories → Paint.  

Start → All programs → Accessories → Run.  

Start → All programs → Accessories → Snipping Tool.  

Start → All programs → Accessories → Sticky Notes.  

Start → All programs → Accessories → WordPad.  

Start → All programs → Accessories → System Tools → Disk Defragmenter.  

Start → All programs → Accessories → System Tools → Disk Cleanup.  

Start → All programs → Accessories → System Tools → System Restore.  

Start → All programs → Accessories → Ease of Access → Ease of Access Center.  

Start → All programs → Accessories → Ease of Access → Magnifier.  

Start → All programs → Accessories → Ease of Access → On-Screen Keyboard.  

Start → All programs → Accessories → Ease of Access → Windows Speech Recognition.  

Start → Help and Support.  

Start → Search programs and files → Write the file/folder name → Enter.  

 

Right click on taskbar → Properties → Toolbars tab →  

Right click on taskbar → Properties → Toolbars tab →  

Right click on taskbar → Properties → Toolbars tab →  

Right click on taskbar → Properties → Toolbars tab →  

Right click on taskbar → Toolbars → Address  

User
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Right click on taskbar → Toolbars → Links  

Right click on taskbar → Toolbars → Tablet PC Input Panel  

Right click on taskbar → Toolbars → Desktop  

Right click on taskbar → Toolbars → Language bar 2  

Right click on taskbar → Cascade Windows.  

Right click on taskbar → Show Windows Stacked.  

Right click on taskbar → Show Windows Side by Side.  

Right click on taskbar → Show the desktop.  

Right click on taskbar → Start Task Manager.  

Right click on taskbar → Lock the taskbar.  

Right click on taskbar → Properties → Taskbar tab → Lock the taskbar.  

Right click on taskbar → Properties → Taskbar tab → Auto-hide the taskbar.  

Right click on taskbar → Properties → Taskbar tab → Use small icons.  

Right click on taskbar → Properties → Taskbar tab → Taskbar location on screen: 

(Bottom / Left /Right/Top).  

Right click on taskbar → Properties → Taskbar tab → Taskbar Button: (Always 

combine, /Combine when taskbar is full / Never Combine).  

Right click on taskbar → Properties → Start Menu tab → Power button action: (Shut 

down/ Log off/ Lock/ Restart/ Switch user/ Sleep).  

 

Right click on the favorite program’s icon in taskbar → Pin this program to taskbar.  

Right click on empty space → New → Folder.  

Right click on the folder / file → Rename → Type in a new name.  

Right click on file / folder → Copy.  

Right click on file / folder → Cut.  
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Open the new location → Right click on empty space → Paste. 
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Computers laboratory (9)          

 

 Right click on file / folder → Delete.  

 

Double left click on Recycle Bin icon→ Right click on file / folder in Recycle Bin→ Delete. 

(To permanently delete a file / folder)  

 

Double left click on Recycle Bin icon →Right click on file / folder in Recycle Bin → 

Restore.  

 

Double left click on Recycle Bin icon → click on Empty the Recycle Bin.  

 

Right click on Recycle Bin icon→ click on Empty Recycle Bin.  

 

Right click on file / folder → Send to → Desktop (Create Shortcut).  

 

Right click on file / folder → Create Shortcut.  

 

Right click on a folder → properties.  

 

Double click on a folder → view menu → Extra Large Icons.  

Large Icons  

Medium Icons  

Small icons  

List  

Details  

Tiles  

Contents  

Double click on a folder → view menu → Details → Click Name header  

Click date modified header  

Click Type header  

Click Size header  

(To sort files in a folder) 
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Computers laboratory (10)          

 Right click in an empty space on the Desktop → Personalize → Desktop Background 

→ Select a picture → Save Changes.  

 Right click in an empty space on the Desktop → Personalize → Desktop Background 

→ Browse → Select background from file browser windows → Ok → Save Changes. 

 Right click in an empty space on the Desktop → Personalize → Screen Saver → choose 

from screen saver list → change the minutes in Wait → OK. 

 Right click in an empty space on the Desktop → Screen Resolution → change the 

resolution slider in resolution address → Ok. 

 Press print screen button on keyboard→ Open a document → Paste. 

 Start→ All Programs→ Accessories→ System Tools→ Disk Cleanup → select the hard 

drive → OK. 

 Double Click on Computer folder → Right-click the local disk → Properties → In 

General tab, Click Disk Cleanup→ OK. 

 Start → All Programs → Accessories→ System Tools→ Disk Defragmenter → Analyze 

disk → Defragment disk. 

 Double Click on Computer folder → Right-click the local disk → Properties → Tools 

tab → Defragment Now → Analyze disk → Defragment disk. 
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Control Panel 

 Start → Control Panel → view by: Category view. 

 Start → Control Panel → view by: Small Icons view. 

 Start → Control Panel → view by: Large Icons view. 

 Start → Control Panel → System and Security → System (windows edition, processor 

speed, RAM size, system type, Windows Activation). 

 Right click on Computer icon → properties → Basic information will appear (windows 

edition, processor speed, RAM size, system type, Windows Activation). 

 Start → Control Panel → Hardware and Sound → Mouse (under the Devices and Printers 

heading) → Mouse properties window will appear. 

 Start → Control Panel → Hardware and Sound → Mouse → buttons tab → in Button 

configuration, Switch primary and secondary buttons → OK. 

 Start → Control Panel → Hardware and Sound → Mouse→ buttons tab →In Double 

Click Speed, Drag the slider → OK. 

 Start → Control Panel → Hardware and Sound → Mouse→ Pointers tab → Select shapes 

of Mouse Pointer→ OK. 

 Start → Control Panel → Hardware and Sound → Mouse→ Pointer Options tab → In 

motion, select a pointer speed → OK. 

 Start → Control Panel → Hardware and Sound → Devices and Printers (all the 

connected devices will be viewed). 

 Start → Devices and Printers (all the connected devices will be viewed). 

 Start → Control Panel → Hardware and Sound → Devices and Printers → Right-click on 

the name of the printer → Set as Default Printer. 

 Start → Devices and Printers → Right-click on the name of the printer → Set as Default 

Printer. 
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 Start → Control Panel → Hardware and Sound → under Sound, Adjust system volume 

→ drag the slider. 

 Control Panel→ Hardware and Sound→ Power Options→ Change battery settings→ 

change plan settings → Save Changes. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



First Class/ Biotechnology Dep. / Mela G. Abdul-Haleem                                                                                                                                                       

58 
 

Computers laboratory (12)          

 

 Start → Control Panel → Category view → Click Uninstall a program link under the Programs category 

→ select the program → Uninstall/Change. 

 Start → Control Panel → Icon view → Programs and Features → select the program → Uninstall/Change. 

 Start → Control Panel → Appearance and Personalization → Personalization → Desktop Background 

→ select a picture → Save Changes.  

 Start → Control Panel → Appearance and Personalization → Personalization → Desktop Background 

→ Browse → Select background from file browser windows → Ok → Save Changes. 

 Start → Control Panel → Appearance and Personalization → Personalization → Screen Saver → choose 

from screen saver list → change the minutes in Wait → OK. 

 Start → Control Panel → Appearance and Personalization → Taskbar and Start Menu → Taskbar tab → 

lock the taskbar. 

 Start → Control Panel → Appearance and Personalization → Taskbar and Start Menu → Taskbar tab → 

Auto-hide the taskbar. 

 Start → Control Panel → Appearance and Personalization → Taskbar and Start Menu → Taskbar tab → 

Use small icons. 

 Start → Control Panel → Appearance and Personalization → Taskbar and Start Menu → Taskbar tab → 

Taskbar location on screen: (Bottom / Left /Right/Top).  

 Start → Control Panel → Appearance and Personalization → Taskbar and Start Menu → Taskbar tab → 

Taskbar Button: (Always combine, /Combine when taskbar is full / Never Combine). 

 Start → Control Panel → Appearance and Personalization → Taskbar and Start Menu → Start Menu tab 

→ Power button action: (Shut down/ Log off/ Lock/ Restart/ Switch user/ Sleep).  

 Start → Control Panel → Appearance and Personalization → Taskbar and Start Menu → Toolbars tab →

/ / / . 

 Start → Control Panel → Appearance and Personalization → Under Folder Options → show hidden files 

and folders → View tab → click show hidden files, folders, or drives → OK. 

 Start → Control Panel → Appearance and Personalization → Under Folder Options → show hidden files 

and folders → View tab → click Don’t show hidden files, folders, or drives → OK. 
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 Start → Control Panel → Appearance and Personalization → Fonts → select a font→ Preview, Delete, 

hide/Show. 

 Start → Control Panel → Clock, Language, and Region → Date and Time → Change date and time. 

 Click the Date/Time displays on the right end of the taskbar → Change Date and Time settings. 

 Start → Control Panel → Clock, Language, and Region → Region and Language →Location tab → select 

current location. 

 Start → Control Panel → Clock, Language, and Region → under Region and Language → Click on the 

Change location link→ select current location. 

 Start → Control Panel → Clock, Language, and Region → Region and Language → Keyboards and 

Languages tab → Change keyboards → select and change the Default input language. 

 Start → Control Panel → Clock, Language, and Region → Region and Language → Keyboards and 

Languages tab → Change keyboards → Add → select a Language → OK. 

 Start → Control Panel → Clock, Language, and Region → Region and Language → Keyboards and 

Languages tab → Change keyboards → select a non-default Language → Remove → OK. 

 

 

 

 

 

 

 

 

 

 


